Connecting to Blynk with serial USB not working

Hi,
I’m trying to use Blynk with my Arduino Mega 2560 using the Arduino_Serial_USB example. I’ve followed the instructions (made sure auth token is right, uploaded to arduino correct port etc) but despite this I’ve had the same error on the 2 PCs I’ve tried this on. When I run the blynk-ser.bat file I get this error:

“‘com2tcp’ is not recognized as an internal or external command,
operable program or batch file.
Reconnecting in 3s…”

It just repeats this message and I can’t type anything else. I made sure to run it on COM3 too. I tried to run the com2tcp application and it closes the instant I launch it, not sure if that has anything to do with it (same thing happened on both PCs I tried). I looked over similar topics in the forums but couldn’t find anyone who had this error message, I’m sure its something obvious but I’d appreciate if someone could help.

Hi, USB sketch says clearly :

for Windows:

  1. Open cmd.exe
  2. write : (your way to blynk-ser.bat folder) example: “cd C:\blynk-library-0.3.1\blynk-library-0.3.1\scripts”
  3. write : “blynk-ser.bat -c COM4” (where COM4 is port with your Arduino)
  4. And press “Enter” , press “Enter” and press “Enter”

Your exception tells me that you didn’t follow point 2.

Much appreciated, I now have it working.
Although, my sketch did not have the same instructions as you’ve posted, it just said:

"Run the script (script located in “scripts” folder of library root,

  • e.g. ‘blynk-library/scripts’) for redirecting traffic to server:
  •  for Windows:         blynk-ser.bat
    
  •  for Linux and OSX:   ./blynk-ser.sh (may need to run with sudo)
    
  • You can specify port, baud rate, and server endpoint like this:
  •  ./blynk-ser.sh -c <serial port> -b <baud rate> -s <server address> -p <server port>
    
  • For instance :
  •  ./blynk-ser.sh -c /dev/ttyACM0 -b 9600 -s cloud.blynk.cc -p 8442"
    

Perhaps I’ve missed something or its just something I should know, I have little experience using the command prompt.
In any case, thanks for your help!

That could be true. We updated sketch 3 weeks ago only. Anyway good that it works now for you =). Happy Blynking!