BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Connecting to blynk-cloud.com:80 ESP8266


#1

Hello, I am having connection issues trying to run my Wemos with blynk.
My code is the following (ESP8266 Standalone example):

/*************************************************************
  Download latest Blynk library here:
    https://github.com/blynkkk/blynk-library/releases/latest

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Follow us:                  http://www.fb.com/blynkapp
                                http://twitter.com/blynk_app

  Blynk library is licensed under MIT license
  This example code is in public domain.

 *************************************************************
  This example runs directly on ESP8266 chip.

  Note: This requires ESP8266 support package:
    https://github.com/esp8266/Arduino

  Please be sure to select the right ESP8266 module
  in the Tools -> Board menu!

  Change WiFi ssid, pass, and Blynk auth token to run :)
  Feel free to apply it to any other example. It's simple!
 *************************************************************/

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "token";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "TP-LINK";
char pass[] = "Pass";

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);
}

void loop()
{
  Blynk.run();
}

It works, but when I reset my router, blynk server does not connect again.
I have the follwoing message continuosly printed:
Connecting to blynk-cloud.com:80

Any idea?
Thanks a lot,
Alberto


#2

I fixed your code formatting, as requested in the instructions you deleted in order to post this :wink:

Blynk - FTFC

Lots…

  • Search this forum for keywords like connection management, reconnection, with or without WiFi, etc. :wink:

HINT, somewhere in here is one… C++ Blynk - Code Examples for Basic Tasks (Work in Progress)

  • Use Blynk.config() not Blynk.begin()

http://docs.blynk.cc/#blynk-firmware-configuration

  • And look in the Docs for connection management commands.

http://docs.blynk.cc/#blynk-firmware-connection-management


#3

My code is just the ESP8266_Standalone example. Do you mean the example needs to be fixed?


#4

No, it means the example is an example… for anything more advanced you need to research and learn.

I already referenced a more advanced example… did you look for it?


#5

I just want to start with the most basic example and then try to do more dificult projects.
I took the following code from one of your examples:

#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "token";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "TP-LINK";
char pass[] = "Pass";

void setup()
{
  // Debug console
  Serial.begin(9600);

  WiFi.begin(ssid, pass); 
  Blynk.config(auth);
  Blynk.connect();
}

void loop()
{
  Blynk.run();
}

And same result:

[5421]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.5.1 on Arduino

[5438] Connecting to blynk-cloud.com:80
[9629] Ready (ping: 1ms).
[109848] Connecting to blynk-cloud.com:80
[116509] Connecting to blynk-cloud.com:80
[123508] Connecting to blynk-cloud.com:80
[130508] Connecting to blynk-cloud.com:80
[137507] Connecting to blynk-cloud.com:80
[144507] Connecting to blynk-cloud.com:80
[151556] Connecting to blynk-cloud.com:80
[158556] Connecting to blynk-cloud.com:80
[165555] Connecting to blynk-cloud.com:80
[172581] Connecting to blynk-cloud.com:80
[179755] Connecting to blynk-cloud.com:80
[186829] Connecting to blynk-cloud.com:80
[193879] Connecting to blynk-cloud.com:80
[201003] Connecting to blynk-cloud.com:80
[208078] Connecting to blynk-cloud.com:80
[215178] Connecting to blynk-cloud.com:80
[222252] Connecting to blynk-cloud.com:80
[229426] Connecting to blynk-cloud.com:80
[236476] Connecting to blynk-cloud.com:80
[243651] Connecting to blynk-cloud.com:80

At [109848] I reset the router and after that, blynk does not reconnect.


#6

No, and it won’t until you add in a bunch more code to make it try to reconnect… as I said, look at the more advanced examples :wink: Check that first link I supplied…


#7

Try using Blynk.begin(auth, ssid, pass);


#8

@ldb OP was already using that :wink: … issue is reconnecting after reset of router. One solution has already been supplied


#9

All good, I suppose didn’t read the beginning properly. :slight_smile: