BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Connecting over USB

#41

@Ivan

do you run this command from scripts folder of blynk library?

0 Likes

#42

i run it from script folders. I go on terminal and type in sudo ./blynk-ser.sh it asks me for a password and i put my user password. and it says “sorry”. Can i use visual studio to run it ?im a newbie i dont really know much.

0 Likes

#43

sometimes this is what it shows up…This script uses socat utility, but could not find it

0 Likes

#44

@Ivan

That’s bad =). It would be much simpler for you to use Ethernet. It will work just out of the box. But if you don’t have Ethernet-WiFi. So you have to install socat by yourself for Mac. That is not trivial.

You need to

sudo port install socat

But “port” also may be no installed on Mac =). So you have to install MacPorts. See for instance this. Hope this helps.

0 Likes

#45

yeah there was a link to do that…but im not going into that haha. i have windows installed on mac. im going to try using that, since i now know how it works i think it will be alright…While i wait for ethernet shield to come. Thanks a lot for your help! really appreciate

1 Like

#46

I’m excited to give this a shot, however, my attempts at connecting the app to the board have failed miserably. I can’t seem to get the board past “[0] Getting IP…” In my own terminal, I get the following when trying to run the blynk-ser.sh script:

Connecting: GOPEN:/dev/cu.usbmodem1451,raw,echo=0,clocal=1,cs8,nonblock=1,ixoff=0,ixon=0,ispeed=9600,ospeed=9600,crtscts=0 <-> openssl-connect:cloud.blynk.cc:8441,cafile=/Users/aaron/Downloads/blynk-library-0.2.4/scripts/certs/server.crt,nodelay
2015/08/02 15:37:08 socat[45091.140735221183232] N opening character device "/dev/cu.usbmodem1451" for reading and writing
2015/08/02 15:37:08 socat[45091.140735221183232] N opening connection to LEN=16 AF=2 45.55.195.102:8441
2015/08/02 15:37:08 socat[45091.140735221183232] N successfully connected from local address LEN=16 AF=2 192.168.1.102:53531
2015/08/02 15:37:09 socat[45091.140735221183232] N trusting certificate, commonName matches
2015/08/02 15:37:09 socat[45091.140735221183232] N SSL connection using AES128-SHA
2015/08/02 15:37:09 socat[45091.140735221183232] N SSL connection compression "none"
2015/08/02 15:37:09 socat[45091.140735221183232] N SSL connection expansion "none"
2015/08/02 15:37:09 socat[45091.140735221183232] N starting data transfer loop with FDs [5,5] and [6,6]
2015/08/02 15:37:25 socat[45091.140735221183232] N socket 2 (fd 6) is at EOF
2015/08/02 15:37:25 socat[45091.140735221183232] W cannot restore terminal settings on fd 5: Bad file descriptor
2015/08/02 15:37:25 socat[45091.140735221183232] N exiting with status 0
Reconnecting in 3s...

After a bit of research, this seems to be a socat issue. I’ve also tried changing the SER, TCP, SSL settings in the script, forwarding the ports, and rebooting my router. Any thoughts, helps, or existing posts are welcome.

0 Likes

#47

Hi guys, i’m super excited i got my Blynk blinking my LED^.^ Now, i’m here to pay it back.

Firstly, i assume the following:
-App downloaded and created new project. The button widget OUTPUT is designated D9.
-Library for arduino is downloaded here https://github.com/blynkkk/blynk-library/releases and the library is installed. <note. if you have not installed, just follow this: in arduino IDE, go to sketch->include library->add .ZIP library (Do not unzip the library. just add it whole)
-Physical circuit is already connected. LED hooked up to pin 9 on arduino.

Step 1
Launch the Blynk app. At the Hex nut icon (beside the play icon), send a copy of the authentication token to your email. Copy this token code from your email.

Step 2
Open up arduino IDE and go to the examples tab and find the BlynkBlink sketch.
The ONLY thing you need to do here is to input your token code. It should come with the " " as well. so mine is

char auth[] = “d87c6fb696bc32hsg1dc16c5b73643b3”;

Then upload the sketch.

Step 3
Unzip the library you downloaded above and then locate this file blynk-ser.bat in the scripts folder. Right click and edit the file with notepad. Here i change ONLY 1 THING, on the 6th line(inclusive of blank spaces) to COM7. (because that is the port my arduino is connected on). Then save and exit,

Final step.
Double click on the blynk-ser.bat you just edited.
This will launch a cmd. window. Next, you press the play symbol on the Blynk app and it will work. BAM.

Hope this works for you. I spent like 1hr trying to piece eveything tgt. total noob here, so you should be on par or even better. Have fun and please support the nice people at Blynk for more fantastic goodies^.^

3 Likes

#48

I have USB connectivity .when I place the token and upload it .it shows compile error.

0 Likes

#49

Are you uploading correct sketch?

0 Likes

#50

yes
this image is taken without connecting with arduino.when i connect with arduino it shows complie error

0 Likes

#51

Please show this error.

0 Likes

#52

0 Likes

#53

How can make my first connection?
Im traing to conect my arduino mega 2560 wiht the app but I can’t.

0 Likes

#54

0 Likes

#55

Plz help i am not able to make projects using blynk.i have usb connectivity only .it shows complie error.

0 Likes

#56

Could you post error?

0 Likes

#57

it shows blynk was not declare .
plz give me comple guidance .i haven’t ethernet sheild.

0 Likes

#58

Try to install latest Arduino IDE - 1.6.5

0 Likes

#59

now program is runing but in applicatin it shows arduino is not in network.i am also edited serial ports in blynk-ser.bat file.

0 Likes

#60

That means you didn’t connected via USB. Please read carefully instructions in sketch.

0 Likes