Can't connect two arduinos at the same time

DHCP on. Ethernet example loaded at both arduino boards (with different auth code). Only one connects to blynk at a time. Get same IP for both, why? One is conneted at the main router, the other to wifi repeater.

Hardware: leonardo (actualy a xboard relay) with integrated WIZ5100 and an Uno with ethernet shield.

serial print from leonardo:

[1515] My IP: 192.168.1.22
[5001] Connecting to cloud.blynk.cc:8442
[12795] Ready (ping: 722ms).

serial print from Uno:

[0] Blynk v0.3.0
[0] Getting IP…
[1913] My IP: 192.168.1.22
[5001] Connecting to cloud.blynk.cc:8442
[10002] Connecting to cloud.blynk.cc:8442

Any ideas?

After several retries, same result… They get the same IP and then one of them doesn’t work… Anybody with the same problem?

From Uno:

[0] Blynk v0.3.0
[0] Getting IP…
[5524] My IP: 192.168.1.25
[5525] Connecting to cloud.blynk.cc:8442
[8899] Ready (ping: 139ms).
[24898] Connecting to cloud.blynk.cc:8442

From Leonardo:

[5525] My IP: 192.168.1.25
[5526] Connecting to cloud.blynk.cc:8442
[5869] Ready (ping: 140ms).
[21870] Heartbeat timeout
[26734] Connecting to cloud.blynk.cc:8442
[27073] Ready (ping: 153ms).

This time only the leonado works (got connected)

EDIT: Finally got them to work! I had to change the manual ethernet example: “server.org” to “cloud.blynk.cc”

Hey, I think you need to specify the MAC address manually (at least for one of them)!
Check the Arduino_Ethernet_Manual example.

1 Like

server.org” to “cloud.blynk.cc” did the trick. The Mac was configured for both. When I changed the server name they started to work both. I tested the bridge implementation which worked also. Now have to check the stability :slight_smile:

1 Like