BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"Can't connect to device"

Hi all
First time using Blynk. Have setup my cloud account and installed the app on my Android device. I’ve taken my ESP8266 and loaded up the Edgent_ESP8266 example and pasted my template ID and device name at the top.

I can load up the app and go to add device, click ready and it finds the AP, shows connecting then eventually a few seconds later fails with “Can’t connect to the device.” Unsure what to do as have updated my IDE to latest version. I’m using the Node MCU 1.0 12-E board as selected board which I believe is correct.

is it #define USE_NODE_MCU_BOARD that I should be un-commenting?

Cheers!

Yes. Do you use ios or android? Could you please send logs with comment “can’t connect to device on provision”

Hi, Thanks for the reply. I use Android as stated in first post and have another device (tablet) that I thought I’d try as I had a feeling it could be to do with the Android 11? The phone is a s20 Ultra. The tablet, however a bit slow, had no problem finishing setting up the connection and all seems well now.

Could it be something to do with the newer Android release or even Samsung?

As for the logs, I’m not quite sure what you mean. Do you mean the serial monitor? IF so, all I get is what is in the picture above, even after the phone states it can’t connect.

Cheers

@CaMo I mean mobile app logs in the left menu “About” section.
@BlynkAndroidDev please take a look.

Have the same problem. I do not know, maybe it depends on Android core version. I have 3 phones with Android 6, 7 and 10. When I’m connecting to the same ESP8266 module, only Android 6 based phone can connect to one. Other 2 phones can connect to AP, but always says “Cant’t connect to device”. Blynk IoT application is the same. 2 logs are sent.

I’ve received logs from several Xiaomi devices about this issue - on both of them app can’t connect to the hardware due to some system issues: probably it is a connected VPN on those devices, but I’m not sure.

Seems to be, these are mine. Tried with VPN turned on and off - the same result. Will try again later.

If possible - send us logs after disabled VPN. Maybe there are some systems alerts - like to allow Blynk IoT app to use Wi-Fi connection, something like that?

1 Like

Bingo! Completely uninstalled VPN apps from the phones and then they can connect to the module. Thank you.

1 Like

Thanks, good to know, we will probably add some notice to the failure screen in such case.

Hi again

I have sent the logs thru via email. Good point, I have Blokada installed my my Ultra so I’ll try again without!

[EDIT]
It works with blokada turned off!

Thanks! :grinning:

1 Like