Cannot get Blynk Server 0.12.6 accessible

I have tried running Blynk Server on an AWS EC2 instance and then my Raspberry Pi when I couldn’t get it working on EC2. Both times when I try to access https://{hostname}:7443/admin I get an ERR_CONNECTION_RESET. I also get this same error message on https://blynk-qa.cloudapp.net:7443/admin. Am I doing something wrong? In both cases I allowed inbound firewall rules for ports 8080, 9443, 8443, 8082, 8081 and 7443 as indicated in server.log. I also generated self signed SSL certs as documented in the GitHub documentation to no success. Before I was just using default configuration with no SSL cert config.

Make sure that your server/admin machine IP address is in the “server.properties” file.
e.g.
allowed.administrator.ips=192.168.1.2

@jcc896 you need to put your IP in allowed.administrator.ips or leave it empty to allow access from everywhere.

1 Like

Doesn’t empty default to localhost only?

@Lichtsignaal default value is for localhost and look like :

allowed.administrator.ips=127.0.0.1

when I say “leave empty” I mean

allowed.administrator.ips=

that is equal for

allowed.administrator.ips=0.0.0.0/0

1 Like

Ah ok, I thought I read somewhere something else.

This changed nothing. I added both localhost (127.0.0.1) to server.properties and used wget https://127.0.0.1:7443/admin and failed along with leaving it blank, doing the same along with accessing it from a browser. This is some fantastic software and I am looking forward to using it an contributing (I am a software engineer).

Allowed IP means - “give access to admin page from that IP”.
So, if your server in AWS instance with IP x.x.x.x and your PC IP is y.y.y.y you should connect to https://x.x.x.x:7443/admin with allowed.administrator.ips=y.y.y.y

1 Like

I tried that sorry. I left it blank saying allowed.adminstrator.ips= and as well as 127.0.0.1. In which point cURL and wget fail at retrieving the URL. I love this software on your public servers but I want to use the REST interface which is only available on local servers. Do the logs output reading the config file (server.properties)?

For reference, this is my admin section:

#ADMINISTRATION SECTION

#admin monitoring port.
server.admin.port=7443
admin.rootPath=/admin
allowed.administrator.ips=192.168.0.0/24

Maybe you missed something? Here it works like a charm on my local RasPi

@jcc896 did you succeed?

Whoops sorry for the delay! I ended up using your Python client. I never could get the server running local or on AWS. Even with local subnet CIDR on the Raspberry Pi, my public IP on AWS. But I think the client you provided somewhere on GitHub is better anyway since it’s lower latency than REST.

Hello,
I have the same problem. I configured my server.properties file as follow:

http.port=8070
stats.print.worker.period=60000
allowed.administrator.ips=0.0.0.0/0
allowed.users.list=

And I couldn’t see the http://AWS-PUBLIC-IP:7443/admin page.

Please if you have success in this process, share with us!

Thank you!

Hello. Should be https.