Cannot get auth token

I have made a new project, my blynk app create it.
After that I pushed E-mail button to send auth token to my mail.
From that moment it passed almost 6 hours and no mail received.
I have closed and opened blynk app several times and I have pushed E-mail button also several times.
Still no mail. I have checked spam too
Have I reached any limit?
Or I must have more pacience?
I that time (6 hours) I have finished my project both hardware and software and I am anxious to try it!
Ios 11.3.1 blynk 2.18.0(1)

Hello. Please check you haven’t made any typo in your registration email. Did you get “greeting” email?

I have logged in with facebook, as I always do, as I logged in here too.
I don"t think they mispelled my email.
And no I didn"t get any greeting mail.
The rest of my projects works fine so my internet connection it’s ok

Meanwhile I deleted my project and recreated again. Blynk app writes in pop-up confirmation window the correct mail adress, but still no mail

What is your login email?

Something wrong with your mail provider or your account settings:

We can’t do nothing here. If you need token you may manually copy it by clicking on it.

Ok thank you.
Something funny is happening.
Other mails are comming to me.
Thank you again, now I understand where is the problem.
Keep on the good working!