Can’t connect Arduino Yun to Blynk using Ethernet

I’ve tried to connect Arduino Yun to Blynk using ethernet, however it didn’t work. I used this example without changing anything except pasting my token. In Blynk app I added button with D13 pin to blink led.
I connected Yun to my router using ethernet cable and uploaded program to Yun using serial port. When I run project on Blynk app it shows “project is offline” message. When I open serial monitor in IDE, it’s empty.
Just in case, I did install all libraries and already tried Blynk with Arduino Uno and USB. It worked fine.
What can I do? Thanks.
P.S. I’ve also tried to connect ethernet cable to my laptop by setting laptop to static IP address. When I then go to http://arduino.local it shows that board is connected to the ethernet. However, I still can’t use Blynk.

Try adding in #define BLYNK_DEBUG at the top of your sketch and report what, if anything, is shown on the IDE monitor.

Thanks for the reply. I did what you advised, but nothing changed. Serial monitor is still empty.

I’ve also tried to use Wi-Fi. The result was the same. And I’ve set up local server using instruction from Blynk youtube channel. Everything was exactly as in the video, except that nothing worked again.

I’ve tried both Mac OS El Capitan and Windows 8. And tried two different networks. I am also pretty sure that board itself is connected to Wi-Fi since I sent commands to it from my laptop via Wi-Fi and everything was working fine.