Can’t buy energy. Im using iphone 6 plus IOS 11.2.1

Need help. I am using blynk version 2.18.0. When i click the Add energy. It just sit there with three dancing dots after I chose the energy pack.

I’m using an iPhone 6 and app version 2.18.0, but with IOS version 11.2.5 and the option to add energy takes me straight to the screen where I choose how much energy I want to buy. I’ve not gone any further, because I don’t want to buy any more energy at present, but it sounds like you’re not getting to that screen.

Have you tried killing the Blynk app (double-click the home button and swipe up) or restarting the phone?

If neither of these works then maybe update your phone to the latest version of IOS.


I’ve try everything. I updated to this ios and blynk but it is still not work. Not sure if it any different with the newer ios.

Maybe try logging out of the app and back in again?


Still doesn’t work

FYI, i do have options to choose the energy pack. I am saying after chosing the energy pack then it just sit there with the dacing dots.

@Eugene please advise.

Check that your payment info is valid. E.g. via System settings -> iTunes & App Store -> Apple ID -> View Apple ID -> Payment Information

Checked that and i do have a valid credit card on the account.

Please turn on the logging (System settings -> Blynk) and send us the logs (from About screen within Blynk app) right after a failure.

Log sent

@khoale012000 Got the logs. The error is that your device is not able or allowed to make payments.

From Apple: An iPhone can be restricted from accessing the Apple App Store. For example, parents can restrict their children’s ability to purchase additional content.

On our side, we’ll fix the app to show this error when user attempts making a purchase.

Thank you. Got it working and purchasing the energy. In-app purchases was turn off.