Bug: device tile value display turns into button

edit: 2 is solved. I needed to add a pin to it.

android galaxy S8. Latest blynk. Server 36.3.

Two issues:

I have one template and behind it are a couple of value displays. These work
When I add second template to the value display 2 things go wrong:

  1. one of the value displays in the first template turn into a button. When I click on its setting it still says its a value display but it displays as a button
  2. the second template does not appear in the device tile when I run the app.

note that when I tried it the second time ‘1’ didn’t happen anymore. but the template still does not display in the device tile

edit: another issue inside the device tile. When you use a superchart then the INPUT - PIN field does not show the current pin. When you click on it it does show the correct pin from the list, but in the overview it looks like its not set.

Which exactly app’s version are you using?

2.21.0 version had some issues with pin’s show, but they were fixed in 2.22.0.

Template are not appearing in the play mode, you need to attach device(s) to it so it will show tile(s) in the play mode.

as said, latest version (at the time of the post) which was/is: 2.22.0

also I can’t repeat it anymore so that will make it hard to track. I also recall it was showing the new type button (but when i selected it during setup mode it showed up as a value display, really weird).
Deleting it and adding it again apparently resolved the issue permanently.