Blynk Video Stream Widget not working with ESP32 OV2460

I have setup an IP cam using an ESP32 and CAM.
The IP cam link is [redacted] if you want to see the format.
It creates a webserver on port 80 and 81, which is portforwarded.
I enter this URL into the Video Stream Widget, it attempts to load, then stays a solid greyish colour, when I tap the screen, a play icons appears, and when I tap that, it goes back to solid grey.
Don’t know why this is happening.

Your stream works for me (Sweden) and that about all the help I can give you :slightly_frowning_face: (I’ve never worked with the video widget)

You might want to change some firewall rules because gives me the settings page for the camera! Not the end of the world, but still :wink:

What happens if you connect the ESP32 and phone to the same Wi-Fi network and use the direct URL (presumably something like deviceIP:81/stream) ?


Yeah I know :rofl:, I don’t care who has access at this point I just want the stream to work

Just tried, exact same outcome. Same blank greyish screen. I’m pretty sure it has something to do with the stream video format that the app / widget doesn’t like. That being said, I have no clue what format it is or how to find out.

Widget supports RTSP (RP, SDP), HTTP/S progressive streaming, HTTP/S live streaming. For more info please follow official Android documentation.


Yeah I have seen this but don’t know what format my stream is to see if it complies.