BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk Server on Google Cloud

That isn’t a server, just a very tiny computer :wink:

Running something called ‘server’ on it doesn’t make your computer a server :stuck_out_tongue:

Actually Wikipedia states exactly the opposite, server is software but over the years computers running server software have been known as servers https://en.wikipedia.org/wiki/Server_(computing)

Being a sysop, I know the line is vague, but the terms have been blurring for years. In practice a server nowadays is a big-ass piece of hardware with outrageous specs at an outrageous price. Seeing as applications have a tendency to be split up in front/middle/back and pieces it’s really hard to tell what is serving and what is clienting.

Putting Blynk on AWS should as easy as stated in the docs anyway :wink:

1 Like

My cat wants food, she then bugs me, so I proceed to Serve’er… Yes! following that logic and your description, I can now identify my purpose in life :stuck_out_tongue_winking_eye:

@MagedNassar The guide is already available… but as stated, it is really recommended for those with more experience and abilities… such as the ability to find and follow the guide :stuck_out_tongue_winking_eye:

Such as this…

http://docs.blynk.cc/#blynk-server

leading to this…

After playing for a while, I subscribed to Google Cloud, managed to establish a new VM and I did run Blynk server on it. The below is what I get when running the server.

Welcome to Cloud Shell! Type "help" to get started.
----@secret-code-193407:~$ java -jar server-0.30.1-java8.jar -dataFolder /home/----/Blynk
Blynk Server  successfully started.
All server output is stored in folder '/home/----/logs' file.
Your Admin login email is admin@blynk.cc
Your Admin password is admin

Now I am trying to open the Admin panel but when I go to:
https://[instance ip]:9443/admin
It is not opening anything!

1 Like

@MagedNassar did you add a server.properties file to the server and if so did you configure it to give remote access to your current WAN IP?

I only added the server.properties file as it is and didn’t modify anything in it.

Looking at the latest version of server.properties it looks like it defaults to access for all IP’s.

Ask Google how to open port 9443.

This is why the recommendation is to use Blynk’s servers.

I did open port tcp:9443 but still unable to get to the dashboard:confused:

To clarify… this was done on your VM in Google Cloud?

Yea. I enabled it for the running instance on google cloud.

OK, now this is a common result of accessing the Admin page in a browser (assuming running a LS inside your home network… aka on a RPi, etc). Normally just click on the advanced and proceed…

image

Perhaps you need to do more on the VM to allow this access?

I am not even reaching this. It just gives the normal “this site can’t be reached”.

I have never used Google Cloud, but you say you ran a VM… can you access that VM as if it were a remote PC and run a “local” browser on it and try from there?

I finally managed to have the server running on GC and I currently have few devices connected to it as well as the mobile app!
Will soon probably have few other questions on my way to learn this new thing :smile:

What was the solution?

I created a new VM using Ubuntu as I was using Debian before. I did the steps in documentation and all worked like a charm. The only thing I did from documentation was how to keep server running on background, instead I used the command nohup &.

Now I have a question, should the server be running as an application attached to the VM or it should be running from the VM itself?

Debian works equally as well as Ubuntu as evidenced by all the “Pi” local servers.

Can you please create a video on steps you performed as many people face the same issue

Excuse me, how did you do it? I’m in that last step like you.