BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk server down - Belgium

#11

Probably.

Save everything you have done and then do what you previously did but with the latest libraries.

0 Likes

#12

Ok i try first update just the libary:
sudo npm install -g blynk-library
than it says i have to update npm and i do too.

but still after running it use the old port :frowning:

OMG —

i use node js for blynk…

So is there a way for delete the old blynk installation and than i will make a new installation?

Because i only use the pi as client, i can nothing lose because its only call the client and than i use it via app project…

0 Likes

#13

Yes, take out the existing SD card and put in another one.

0 Likes

#14

haha i still use ssd anyway… so that means i cant use blynk client longer on my installation?

I start the full instalation procedure as you suggest. But i get an error at that point: sudo npm install -g onoff

but after sudo npm install -g blynk-library it says updated

but when i run the client it still connect at 8441 :frowning: so is there any oportunity to edit the libary ports byself? maybe i delete some folders? and reinstall it ?

redirect 8441 to 80 ?

0 Likes

#15

Do you have 5 SSD’s for the 5 Pi’s that you are using or do you have more than 5 SSD’s?

I don’t do much Pi / Blynk stuff these days so I’m not going to guess the “upgrade” procedure.

From memory aren’t the ports declared in one of the scripts?

If you have a spare SSD I would start with a fresh install of the latest libraries etc. You can always copy over the projects when you are up an running again.

0 Likes

#16

I have some basics here… assuming the new client install isn’t using the proper port (I use Local Server, so I don’t know) then I guess you could just as easily use the Local Server method, but point right back to the Cloud Server IP (still recommended to use port 8080 anyhow)

0 Likes

#17

blynk client is just for the remot controll of my servers…
for me would be the easyst way with port rules…
so i understand the old port is 8441 and the new is now 9443 ?
Or maybe i can delete the old libary in the folder install it new, because when the new libary has the correct client ports, so it must be in any cache , so if i delete all files and than install new, should be work?
what folder files i can delete any suggestions?

I just wondering that it works until today and now all stop after server down time…

Thanks

0 Likes

#18

What servers? Blynk servers? How do you use a Blynk client application to control a server?

9443 is for the App, not the device… the default port for all client devices is 8080 (although in some cases just the usual 80 will work)

0 Likes

#19

Same problem for me on pi after servers crash. Trying update blynk-library is not working for me too (stiil trying to connect through 8441 port). Kinda dont know what to do now :roll_eyes:

0 Likes

#20

I suspect the old ports left you connected until such time as the server was rebooted and now you need the new ports.

I am 99% certain that the ports are in a script and you should be able to edit the script. I don’t know if any other parts of the script have changed in recent months though.

0 Likes

#21

@Guido_Solar @Viperuss Just remove the old and update to the newer library… it was changed about 10 months ago, and this server issue is clearly requiring the new port (80, although 8080 in a manual setting should work as well).

0 Likes

#22

Actually on reflection it’s the USB connection method scripts that have the port details.

0 Likes

#23

If you understand GitHub notation for commits you could try editing the ports yourself from this commit:

0 Likes

#24

not working for me I guess… Am I doing it right? :face_with_raised_eyebrow:

0 Likes

#25

I don’t know what you are doing… so I can’t say :stuck_out_tongue:

0 Likes

#26

@Costas there are many other changes and even some widget control additions to the rest of the library as well.

0 Likes

#27

That’s why I suggested a new SD / SSD but for a few lucky punters a port change edit will “work”.

0 Likes

#28

True… but if they have the skillset to edit the correct file directly on the RPi without messing up total operation, then they will have already simply updated to the current version.

0 Likes

#29

GitHub shows the edit so even a monkey could do it :slight_smile:

0 Likes

#30

True… as I have demonstrated :rofl:

Actually, as referenced before, I think even just changing the one connection command in the script itself will work.

1 Like