Blynk server connection error with SIM900 GSM module

Hi there, My SIM900 GSM module isn’t connecting to the Blynk server. Getting the following o/p on the Arduino serial monitor. Appreciate any help.

[365305] Connecting to

My code below============================================================

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space

// Default heartbeat interval for GSM is 60
// If you want override this value, uncomment and set this option:
//#define BLYNK_HEARTBEAT 30

// Select your modem:
//#define TINY_GSM_MODEM_SIM800
// #define TINY_GSM_MODEM_SIM808
// #define TINY_GSM_MODEM_A6
// #define TINY_GSM_MODEM_A7
// #define TINY_GSM_MODEM_M590
// #define TINY_GSM_MODEM_ESP8266

#include <TinyGsmClient.h>
#include <BlynkSimpleSIM800.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
const char auth[] = "12c1f92658864171b3c1aef130e1a5de";

// Your GPRS credentials
// Leave empty, if missing user or pass
const char apn[]  = "everywhere";
const char user[] = "";
const char pass[] = "";

// Hardware Serial on Mega, Leonardo, Micro
//#define SerialAT Serial1

// or Software Serial on Uno, Nano
#include <SoftwareSerial.h>
SoftwareSerial SerialAT(7, 8); // RX, TX

TinyGsm modem(SerialAT);

void setup()
  // Set console baud rate

  // Set GSM module baud rate

  // Restart takes quite some time
  // To skip it, call init() instead of restart()
  Serial.println("Initializing modem...");

  String modemInfo = modem.getModemInfo();
  Serial.print("Modem: ");

  // Unlock your SIM card with a PIN

  Blynk.begin(auth, modem, apn, user, pass);

void loop()

What MCU are you using?

Have you had successful results connecting and utilising the SIM900 GSM module without Blynk first?
!! Highly Recommended !!

Have you tried any other connection methods to Blynk with your MCU?

Hi Gunner,

I am using arduino uno.

Yes, I can make calls with the SIM900 module and it connects to GPRS.

Yes, the same arduino Uno connects to Blynk via ethernet shield without any problem.

Thanks in advance

Perhaps your BAUD rate is set too fast… Often with UNO and ESP as shield 9600 is the recommended rate.

Tried 9600 also with no luck.

Do you need to manually configure BAUD rate in the GSM module as well? like needs to be done with ESP.

I just changed the code to 9600

Both code and hardware settings need to match each other whenever changed.

Yes, just changed the hardware rate also. Both 9600 now. But, still the same issue.

Connecting to

Try different pins… UNO usually works fine with 2 & 3 or 10 & 11 And of course make sure the RX of the UNO goes to the TX of the module, and vice versa.

1 Like

Just changed to 2,3 and to give you an idea. This what I am seeing on the serial monitor. The same as before. Looks like the connection is failing at the server.

Initializing modem…
Modem: SIM900 R11.0
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.4.8 on Arduino Uno

[12759] Modem init…
[13698] Connecting to network…
[13993] Network: EE
[13993] Connecting to everywhere …
[20528] Connected to GPRS
[20797] Connecting to
[31333] Connecting to

what firmware version do you have on the sim900?
did you ever managed to use that module in other projects?

make sure the baud rate is 9600 on the software serial, arduino can’t handle much

You do have a Cloud Server account, right? and have created a Project and received the token, etc… Have you ever had a connection to your server account with any other MCU?

Is there a possibility that your GSM module is connecting to a different server, due to however your mobile service provider works?? I guess you can try pinging from your PC and force using that IP in your sketch.

Just went through both of those :wink:

Hi Wanek, not sure how to check the firmware version. But, answer to other 2 questions ‘yes’.

ok, i’m on phone now, but if you google sim900 firmware version, it will eventually give you an at command, like AT+GSV.

you can upload the sketch in the built in tinygsm library example (in arduino ide menu) to use at commands, and you can introduce there. some sim900 modules have VERY old fw and can not handle all commands for gprs.

i’m not sure if this is your problem actually, but post here the fw version you have.

edit: i found it, corrected my post

1 Like

Yes, I have a cloud server account and received the token etc…
Yes, the same MCU works fine with the ethernet shield (another token).

I used to have a SIM800L module and it worked fine before.

yes, sim8xx series are better / newer than the sim9xx.
i also have both, and the sim900 is working unreliably.

may i ask where are you from (country)? and where did you bought the sim800L?

Bought it through amazon UK.

Firmware info below.


ok, that is the newest fw for sim900, so that could not be the problem.