BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk-ser.sh usb script issue on raspberry pi 4 and local server

Hi everyone, I ask for your help for a problem that I can’t solve. I am new to the raspberry world and linux in general. In the past I already managed to install and configure the local blynk server and the usb script (for an arduino nano running the blynk sketch) on a windows pc. Currently I managed to start and configure the local blynk server on my raspberry pi 4 and I can log in from the app on iOS. But when I start the usb script a connection is not established. I state that an arduino nano with the configured sketch and the correct aut code is connected to the raspberry. Thank you and sorry for my English.

You have to change the script as follows:

  1. To not use SSL
  2. To use correct hardware port 8080
  3. To change baud rate according to your speed settings of /dev/ttyUSB0
  4. To use the correct IP or DDNS address of your Local Server
....
# === Edit default options to match your need ===

FROM_TYPE="SER" # SER, TCP
#For SSL, must have correct server.crt for local server, such as "server-yours.crt"
#TO_TYPE="SSL"   # TCP, SSL
#For TCP
TO_TYPE="TCP"   # TCP, SSL

# Must match baud rate in sketch
#COMM_BAUD=9600
COMM_BAUD=115200

# Must match server DDNS or IP
#SERV_ADDR=blynk-cloud.com
SERV_ADDR=192.168.178.110
#SERV_ADDR=your-account.duckdns.org

# Must match server hardware port, 9443 for SSL and 8080 for TCP
#SERV_PORT_SSL=443
#SERV_PORT_SSL=9443
#SERV_PORT_TCP=80
SERV_PORT_TCP=8080

#LSTN_PORT=80
LSTN_PORT=80

#For SSL, must have correct server.crt for local server, such as "server-yours.crt"
#SRVR_CERT="$SCRIPTPATH/certs/server.crt"
SRVR_CERT="$SCRIPTPATH/certs/server-yours.crt"
CLNT_CERT="$SCRIPTPATH/certs/client.pem"
...

then just issue simple command

sudo blynk-ser.sh

or issue the correct complete command without modifying the script for TCP connection

sudo blynk-ser.sh -c /dev/ttyUSB0> -b 115200 -s 192.168.178.110 -p 8080 -t TCP