Blynk protocol digging and questions

Hello as I have a problem to add blynk at my environment Eclipce+SDK+ESP8266. I decide to add basic blynk functions to my project using protocol description. Also I flashed into ESP8266 demo code using Arduino IDE in #define BLYNK_DEBUG mode. So I get following in terminal:

[151751] Connected to WiFi
[151751] My IP:
[151751] Blynk v0.3.0
[151751] Connecting to
[157807] Connecting to
[164956] Connecting to
[169122] <msg 2,1,32
[169746] >msg 0,1,200
[169746] Ready (ping: 8ms).
[169746] >msg 20,12,8
[179739] <msg 6,1,0
[179894] >msg 0,1,200
[189893] <msg 6,2,0

So “<msg 2,1,32” is a “BLYNK_CMD_LOGIN = 2”, and “1” message ID,“32” is a length of Auth string “<3ffae384dc5b4f079faf6a8f956aa034”
then comes
“>msg 20,12,8” is a “BLYNK_CMD_HARDWARE = 20” I don’t know what is this?
and than comes “>pm0out” GIPO 0 settings
and in the end pair
[179739] <msg 6,1,0 //Ping
[179894] >msg 0,1,200//OK
So I decided to test connection in TCP client program Hercules terminal and I connect to “” “8442” and send

02 01 20

“msg 2,1,32” in hex and then

3f fa e3 84 dc 5b 4f 07 9f af 6a 8f 95 6a a0 34

Auth in hex. And I get no response complete silence. Help me what I am duing wrong?
P.S. For this post I change 1 byte in Auth to prevent hanging of my arduino.

It better to install local server for tests it have trace output by default so you’ll quickly see exactly problem and what are you doing wrong. To be honest I didn’t get what your question from above post =). Why auth is hex? It should be plain string

This is hardware command, means command for hardware.

Thanks to Dmitriy and Blynk team i solved my problem. Here is my log in hex:­

msg 2,1,32­


msg 0,1,200­

msg 6,1,0­

msg 0,1,200­

msg 20,12,8­


msg 6,1,0­

msg 0,1,200­





Waiting for post in your Blog :wink:

Yes wait for updates on

Just wrote an article. Led controlled by Blynk. Using NodeMcu Esp8266 board + custom project in Eclipse SDK.

1 Like

Cool! Small remark - we are from Ukraine. Not Russia =).

I corrected this terrible mistake))))
Nice to see fellow countrymen!!!