Blynk + IFTTT Wrong request format

Hello everyone,
I try to connect my project with IFTTT. I found many tutorials how to do that and almost each of them has different answer. (For example here it is said that I can use either PUT or GET and many said it has to be GET - I disagree. )
I tried various options in my project but something is still wrong and miss the error.

I want to turn ON/OFF a LED light bulb. I use no relay module for now, I will change the LED into regular bulb after it works with LED. Does it make a change? The Blynk construction works perfectly fine.
I use pin D7.
IFTTT settings:
Method: PUT
Content: application/json
Body: [“0”] for ON and [“1”] for OFF

After typing the URL I get the message: Wrong request format.

• NodeMCU ESP8266
• Smartphone with iOS
• Blynk server

Thanks for help :stuck_out_tongue:

I think you’ll find that many people, myself included, feel that GET is the better approach to take, and that the full command (which you can test in your web browser) should go in the URL and the Body should be empty.

Clearly your approach isn’t working, maybe because you’re using https - unless that’s a typo, but why disagree with people who have done this successfully before?

Have you tried a GET with this as the URL and the body empty…

If you get to the point where IFTTT is happy with the command, but your NodeMCU doesn’t appear to be responding, then change the D7 to D13 and see if that turns the D7 pin on/off.


I mean, I disagree with opinion that GET is the only possible option. Many others also used PUT and it worked :slight_smile: Thank you for answering, I will test it right away.