via clientConnect and php on a webserver

I am using email to have the Wemos D1 Mini board send me a true SSM text message, but am having problems with the function. It works, but there are concerns with it. First, if the project in the app (on my android phone) is in edit mode or just not running, I don’t get any email from my code. Also, if instead I use an SMS type email like for example it simply does not work with either . So instead I’d like to call a small php mail command from my Godaddy server. The php code works great to use email to send me a SMS Text Message. I’ve seen how to use GET using variables to pass to php, but I’m confused with the coding of the Wemos Mini Pro board. All I get for the connectionValue variable is zero every second. My webserver has SSL on it.

#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>
#include <WiFiClient.h>

char auth[] = "W4ZL-zr7e3r4UIHx0gO1PzHKuTQyZD6h";
char ssid[] = "mynetwork";
char pass[] = "mypassword";
int connectionValue;

BlynkTimer timer;
WiFiClient client;

void mainLoop()
  connectionValue = client.connect("", 443);
  if(connectionValue) {
    client.println("GET /email.php?subject=Flood&message=Furnace Room");
void setup() {
  Blynk.begin(auth, ssid, pass);
  timer.setInterval(1000L, mainLoop);
void loop()

To successfully access your SSL WebServer, you have to use

  1. WiFiClientSecure httpsClient
  2. Some SHA1 fingerprint from your WebServer

You can have a look at WiFiClientSecure example HTTPSRequest.ino in ESP8266 core library ESP8266WiFi


Will I be able to use my current code AND this new code together? I’ll try it tomorrow. I think I’ll have more questions as the new code has unfamiliar commands. I’ll see. Thanks for pointing me in the right direction. I didn’t know where to begin and had spent many hours trying to find how to do this.

Is it possible that the problems that you are seeing with Blynk email are occurring because you are exceeding the default 120 character limit for everything within the command?
Your target email address is quite long and this counts towards the 120 character limit.

See the documentation here for more details, and for information on how to increase this limit to upto 10 times the default:

There are also other restrictions on the frequency and maximum number of messages per day, which are documented in the link above.

Also, the SMS gateway you are using may not support HTML message formats, so have you tried setting the widget to text/plain?


My subject and message are a few words each so not close to maximum. I did try the text/plain option without success.