BLYNK connectivity issues with M3000 Hotspot


I am trying to use an Inseego MiFi X PRO (M3000) hotspot to connect a WeMos D1 Mini (ESP8266) to the internet to use with Blynk. The M3000 hotspot has an ethernet out port which I am connecting to a router (GL.iNet GL-AX1800 Flint) to broadcast the signal.

The issue is that when the ESP8266 is connected to the router’s WiFi signal, the ESP8266 is able to ping the blynk servers and connect, but none of the BLYNK_WRITE callbacks ever fire. If I change only the portion of the code to connect directly to the M3000 hotspot’s WiFi, the callbacks fire normally. Is there some port that could be blocked when using the ethernet connection? As a troubleshooting step, I also tested with connecting the hotspot to my home router which is a TP-Link with the same issue. I am able to use Blynk.sendInternal() to receive utc time updates however. Any help would be appreciated.

This is the initial connection debug info print out for the connection with issues:

___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
    /___/ v1.2.0 on ESP8266


[76] Connecting to
[79] Connecting to
[5077] Connecting to  
[5077] Connecting to
[10078] Connecting to
[11158] <[1D|00|01|00|20]fkY_GzSnp2MVq31eh4iSj6UIne4-RFY0
[11215] >[00|00|01|00|C8]  
[11215] Ready (ping: 56ms).
[11215] Free RAM: 47664    
[11282] <[11|00|02|00]zver[00]1.2.0[00]h-beat[00]45[00]buff-in[00]1024[00]dev[00]ESP8266[00]fw-type[00]TMPL2fpNoMEL-[00]fw[00]0.1.0[00]build[00]Jun[20]30[20]2023[20]13:16:28[00]tmpl[00]TMPL2fpNoMEL-[00]

Here is my blynk connection code:

void blynk_setup() {
  // Setup WiFi network
  WiFi.begin(ssid, pass);
  // Setup Blynk
  Blynk.config(BLYNK_AUTH_TOKEN, "", 80);
  while (Blynk.connect() == false) {

It sounds like an issue with the way that the MiFi device is filtering some of the data it’s outputting on its LAN port.


I’ve looked into that but haven’t been able to find any setting that seems to be causing that. IPv4 and IPv6 are both turned on, no port filtering or port forwarding. VPN passthrough is enabled as well as WAN Ping Enablement. DMZ is not enabled. I’m not a networking guy… do any of these settings sound like they could help? All other internet services seem to work fine with the setup besides Blynk.

Instead of using the Hotspot’s ethernet output. I USB tethered the hotspot to the router to share the internet connection. For whatever reason, this has mitigated the problem for now.

Which seems to support my theory that…