Blynk app on particle core with pi server "not in network error"

I have a simple app on a Particle Core (really a Spark Core) that I have been running on the Blynk server for months with no problem. I set-up a raspberry Pi 3 server a few days ago and ESP8266 apps work fine but the Particle Core app that was working on the Blynk server won’t connect to the Pi server. I have tried several new tokens and logged in a couple of times. The Particle Core seems to be flashing fine.Any ideas why?

What does the serial output say from the particle and what does the blynk.log file say when you connect/reset the hardware? Those are your first clues in troubleshooting :slight_smile:

Serial output shows the value from the sensors on the particle core as expected. The Blynk log file shows it is connected so that isn’t the issue. Seems it is a Pi connection issue.Rebooting the Pi server didn’t help. I tried various forms of the Arduino Blynk.begin(auth) statement with no luck, e.g. Blynk.begin(auth, “SSID”, “PW”, IPAddress(192,168,1,xxx)); which works fine with arduino sketches.

If you are logged on the Pi via SSH or console, can you do a telnet localhost 8442 ? This wil indicate wether the server has started correct.

I have a ESP8266 running on the same Pi server with with Blynk and there is no problem. Pi log file says the Blynk app has logged in.

Particle Build throws this error with Blynk example:
This is the Blynk example: Blynk.begin(auth, SSID, pass, IPAddress(XXX,XXX,XXX,XXX));
This is my info: Blynk.begin(auth,“MYSSID”,“MYPW”,IPAddress(192,168,1,15));
This is the error:bed_room_pi.cpp:42:64: error: no matching function for call to ‘BlynkParticle::begin(char [33], const char [9], const char [8], IPAddress)’
I also tried the Blynk example with this set-up and it wouldn’t build either.

The app will build if I leave out the ssid and pw but the particle still won’t connect to the server. I’ve tried the ssid and pw without " " but it still throws an error.

Also when this app is flashed the server won’t stay online. With only the ESP8266 on the Pi server and the particle on the blynk server, the blynk server is solid.
device came onlineno dataNovember 8th at 2:08:56 pmPW
{“data”:“online”,“ttl”:“60”,“published_at”:“2016-11-08T22:08:56.352Z”,“coreid”:“53ff6b066667574818202467”,“name”:“spark/status”}
device came onlineno dataNovember 8th at 2:06:43 pmPW
{“data”:“online”,“ttl”:“60”,“published_at”:“2016-11-08T22:06:43.396Z”,“coreid”:“53ff6b066667574818202467”,“name”:“spark/status”}
device went offlineno dataNovember 8th at 2:06:20 pmPW
{“data”:“offline”,“ttl”:“60”,“published_at”:“2016-11-08T22:06:20.071Z”,“coreid”:“53ff6b066667574818202467”,“name”:“spark/status”}
device came onlineno dataNovember 8th at 2:05:06 pmPW
{“data”:“online”,“ttl”:“60”,“published_at”:“2016-11-08T22:05:06.569Z”,“coreid”:“53ff6b066667574818202467”,“name”:“spark/status”}
device went offlineno dataNovember 8th at 2:05:02 pmPW
{“data”:“offline”,“ttl”:“60”,“published_at”:“2016-11-08T22:05:02.161Z”,“coreid”:“53ff6b066667574818202467”,“name”:“spark/status”}
device came online

are you able to make accounts and login to Pi via mobile app?

Yes, but only to the ESP8266.

Can you show us the particle sketch? From the error I think there are some variables for setting up the connection missing. What you can also try is not using IPAddress(x,x,x,x) but “192.168.x.x” (being your real Pi IP of course, including quotes).