Blynk App (on iPhone) not working when coming out of Background


I’ve just noticed in last 24 hours strange behaviour,
i “double click home button” on iPhone and scroll through to select Blynk App which is running in background for some time. Then I select a button widget in my Blynk app and nothing happens. To correct this I need to kill the Blynk App then re-run it and it works again. Seems to only occur when Blynk app has been running as a background app on iphone for some time.

Anyone else notice this behaviour recently ?

I am running Blynk 0.3.4.

Kind Regards

@ashvetsov please have a look.

@mars,which version of Blynk application are you using?

version 2.1 on ioS. I am using a local blynk server 0.3.4.
I’m trying to best make it repeatable. Seems to be working ok for last few hours. I will report if I can somehow workout what steps make it repeatable.

Thanks a lot, @mars! I will try to reproduce it too (unfortunately me previous attempts were not successful)

Hi BlynkiOSDev @ashvetsov @Dmitriy

I believe seem to have found a way to reproduce issue.
Step 1: I run the Blynk app while I am connected to my WiFi Access Point. I have a simple Blynk App i.e. press Button in Blynk App to light up a virtual led in the Blynk App.

Step 2: I press the Apple Home button so Blynk app goes into the background. Importantly I do this while I am still in range of my WiFi Access point and still connected to it.

Step 3: I then walk away so that I am OUT OF RANGE from my WiFI access point and wait there for around 5 mins.

Step 4: I then walk back so I am in range of the WiFi Access point (the same one as Step 1). I simple wait for the WiFi Icon to appear top left of iPhone screen.

Step 5: Now I bring the Blynk App (that is running int he Background) back to the foreground. I then press the same button as Step 1 and nothing happens. I need to kill the Blynk App and restart in order for it to work (or I need to TURN WIFI off while App is running and TURN back on).

Hope you can re-produce same issue.

Kind Regards

Dear @mars. I checked this on my side and unfortunately issue is still not reproducible.
So lets try investigate more. What exactly doesn’t work on your side? Would be great if you share you project configuration with me (sketch on board, widgets and corresponding pins on app).

Hi @Artem_S I am still getting issue of application on iOS coming out of background no being able to communicate to local server but interestingly the Blynk App does not show disconnect message.

Is there anyway I can run iOS Blynk App in Debug mode or get log information on the App then send across to you for analysis ? I really want to help debug this issue as I’m sure its happening for others.

Kind Regards

Hi; this is still an issue for me and occurs at least once a day. Is there anyway I can send logs from my IOS Blynk app to yourself so you can see if there are any clues ?