Biometrics authentication on Blynk new app is not working

Hi all,

I’ve the Blynk new app and I’ve activated biometrics authentication to access my device, but has been a week that every time I open the app I’m not asket for my biometrics but rather to access it’s required the PW.
Is anyone experimenting the same issue?

Furthermore I’ve tried to reset the PW from the app, but never received the mail to reset the PW (had to do the process from the PC).

Hope in yours support :slight_smile:

iOS or Android?
App version?
What biometric devices does your phone have?


Hi Pete,

IOS 16.0
Blynk Version 3.4.3 (0) (on app store there are no new updates)
Finger print reader on home button


It works for me on an iPad with fingerprint sensor…

and on an iPhone with face detection.

It does seem that if you don’t unlock the app with the touch sensor and log-in instead then biometric authentication is turned off.


Yes was working well like on your Ipad till last week and yes if you fail to use the biometric lo log in then PW it’s required.
But my scenario is the same:

  1. I open Blynk app and it ask me to log in or register
  2. I click on Log In as I’ma registered user and I end up in the page where my credentials are requested (my email is prefilled)
  3. I input my PW and press Log In
    (btw if I try to reset my PW from here it doesn’t work, but not the main issue now as form desktop it’s working)
    As soon as I press log in it require my biometric
  4. I’m finally inside my app…
    I’ve also checked that biometric it’s enabled and indeed it is

    I do what I have to do with the app then I close it.
    When I reopen again the app I find myself back at point 1) no matther if I’ve closed the app 1sec before or 2hrs.
    While before as soon as I was opening my app I was asked for biometric (as you Pete on your Ipad)

Basically it’s like closing the app means being logged out and every time I open the app I need to log in again.
(I’ve also tried to disable biometrics but I’m having the same issue, every time I close the app when I reopen I need to log in again).

If anyone has idea why this is happening let me know

@Eugene this isn’t how it works for me on my iPad, but does it make any sense to you?


@onal Please do the following:
Go to System Settings → Blynk and enable logging there
Go to Blynk app, login if needed, use a bit to make sure the internet connection is stable
Go to Blynk left menu and Log Out from there
Relaunch the app, log in, relaunch again, etc.
If the issue still there, go to left menu → About and send us app logs from there

1 Like

Done the procedure suggested but still experimenting the descrived behaviour where every time I relaunch the app I’m requested to log in (desppite biometric are enabled or not).
I’ve sent a log

Thanks for the logs.
Yeah, I don’t think this has smth to do with biometrics. Looks like account info is just not saved in the keychain. I’ll need to add more detailed logs of why this happens on your iPhone.
This iPhone is not jailbroken, not under MDM or anything like that?
I’d also recommend trying remove the app and install fresh copy from App Store.

Yes I don’t think either it’s the biometrics, as even disabling it the behaviour is the same.
Nope, not a jailbroke or under MDM, is the same old phone I’ve been using.
I’ve tried to remove the app and reinstall from AppStore, but still same behaviour (both with biometrics enabled or not).
I’ve also tried to restart the phone (sometimes this make magic :slight_smile: )

Hi @Eugene
did you manage to understand what could be the issue? there is anything more I can do to help debugging?

@onal no.
When the app update available I’ll ping you here to send new logs after update.

@onal Please update the app in App Store, if the issue persists, send us new logs from within the app.

@Eugene tnx, I’ve done it already, was waiting to use a bit to check in the bug was fixed and I’m happy to confirm that YES the issue it’s solved tnx!
Thread closed on my side :slight_smile:

1 Like