BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino uno with Nodemcu(as wifi shield)


#21

So what happens if you put the IP address in the correct format?

Pete.


#22

We need all the Serial Monitor data for your connections to the Blynk server and the line of code you are using to connect to it.


#23

OK . Now i need to try this out. And i will let you know if that works.


#24

Make sure you are using a new token in your sketch for connection to the Blynk server.


#25

Yep am aware of it. Because i created a new project and i got an auth token from the blynk server and the same auth token was flashed.


#26

Took me about that long with an ESP01, never again :slight_smile:


#27

If any one got this up and running. Please tell me which version of the Arduino IDE , AT Firmware and Blynk li version. So that i can try the same.


#28

Firmware version is less important than correct IP address syntax :slight_smile:


#29
#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h> // include Blynk ESP8266
#define BLYNK_PRINT Serial  // Comment this out to disable prints and save space
#define BLYNK_DEBUG

char auth[] = "xxxxxxxxxxxxxxxxxxxx";
char ssid[] = "xxxx";
char pass[] = "xxxx";
char server[] = "xxx.xxx.x.xxx";
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // ( RX, TX )
#define ESP8266_BAUD 9600
#define server "192.168.1.169"
ESP8266 wifi(&EspSerial);

//Relay in Pin XX
#define Relay1 10
#define Relay2 9
#define Relay3 8
#define Relay4 7
#define Relay5 6
#define Relay6 5

// in Blynk app writes values to the Virtual Pin 1
BLYNK_WRITE(V1)
{
  int RelayStatus1 = param.asInt();
  if (RelayStatus1 == 1) {
    digitalWrite(Relay1, LOW);
  }
  else {
    digitalWrite(Relay1, HIGH);
  }
}

BLYNK_WRITE(V2)
{
  int RelayStatus2 = param.asInt();
  if (RelayStatus2 == 1) {
    digitalWrite(Relay2, LOW);
  }
  else {
    digitalWrite(Relay2, HIGH);
  }
}

BLYNK_WRITE(V3)
{
  int RelayStatus3 = param.asInt();
  if (RelayStatus3 == 1) {
    digitalWrite(Relay3, LOW);
  }
  else {
    digitalWrite(Relay3, HIGH);
  }
}


BLYNK_WRITE(V4)
{
  int RelayStatus4 = param.asInt();
  if (RelayStatus4 == 1) {
    digitalWrite(Relay4, LOW);
  }
  else {
    digitalWrite(Relay4, HIGH);
  }
}

BLYNK_WRITE(V5)
{
  int RelayStatus5 = param.asInt();
  if (RelayStatus5 == 1) {
    digitalWrite(Relay5, LOW);
  }
  else {
    digitalWrite(Relay5, HIGH);
  }
}

BLYNK_WRITE(V6)
{
  int RelayStatus6 = param.asInt();
  if (RelayStatus6 == 1) {
    digitalWrite(Relay6, LOW);
  }
  else {
    digitalWrite(Relay6, HIGH);
  }
}

void setup()
{

  pinMode(Relay1, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay1, HIGH); // Prevents relays from starting up engaged

  pinMode(Relay2, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay2, HIGH); // Prevents relays from starting up engaged

  pinMode(Relay3, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay3, HIGH); // Prevents relays from starting up engaged

  pinMode(Relay4, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay4, HIGH); // Prevents relays from starting up engaged

  pinMode(Relay5, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay5, HIGH); // Prevents relays from starting up engaged

  pinMode(Relay6, OUTPUT); // sets the digital pin as output
  digitalWrite(Relay6, HIGH); // Prevents relays from starting up engaged

  // communication with the host computer
  Serial.begin(9600);
  delay(10);
  // Set ESP8266 baud rate
  EspSerial.begin(ESP8266_BAUD);
  delay(10);

  Blynk.begin(auth, wifi, ssid, pass, server);
  //Blynk.begin(auth, ssid, pass, IPAddress(1xx,1xx,1,1xx), 8080);
  //Blynk.begin(auth, wifi, "xxx", "xxx", "19x1xx1,1xxx", 8080);
}

void loop()
{
  Blynk.run();
}

Some one the community got this sketch running. So just changed the token , ssid and pass.
But did not work.

Right now am running several Arduino IDE versions on my laptop !! Is that causing any issue ? Because ex. Attiny85 works on 1.0.6 and not anything above it.


#30

Yes am about to try that out.
Do you suggest me to uninstall the arduino IDE and Blynk lib and install everything new !!
Will this Fix the issue ?


#31

That definition only counts if it hurts :scream: … when you have mad wiring and soldering skilz it is easy to hook up :stuck_out_tongue_winking_eye: Every wire in its proper place… just … don’t… sneeze… :rofl::rofl::rofl:

Heck, I still use USB link :open_mouth:


#32

Good for them but I would go back to the super short sketch.

There are problems with IDE’s older than 1.8.8 when using an ESP development board for it’s intended purpose i.e. not a shield. Don’t know about shield mode.

If it’s not a problem then yes kill everything and use 1.8.8.


#33

Right now am using

AT Firmware
AT version:1.1.0.0(May 11 2016 18:09:56) [Blynk suggested]
SDK version:1.5.4(baaeaebb)

(and also other latest few, and too old as well)

Arduino IDE
1.8.5
also tried with
1.8.3
1.8.2
1.6.4

Blynk Lib version
0.4.8 [tried 0.3.3, 0.5.8]

oki will install 1.8.8

and what about the Blynk lib version ?


#34

@Madhukesh It doesn’t really matter what AT firmware version you are using… although newer Blynk versions are usually better for Blynk purposes. I am also currently running IDE 1.8.7

I am using this with a ESP-01 and Arduino Mega on a Local Server.

[1243] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.6.0 on Arduino Mega

[1751] Connecting to GunnersZone
[4810] AT version:1.2.0.0(Jul  1 2016 20:04:45)
SDK version:1.5.4.1(39cb9a32)
Ai-Thinker Technology Co., Ltd.
Integrated AiCloud 2.0 v0.0.0.3
Build:1.5.4.1 Jan 10 2017 18:32:04
OK
[9866] +CIFSR:STAIP,"10.10.3.178"
+CIFSR:STAMAC,"5c:cf:7f:3c:b2:08"
[9867] Connected to WiFi
[19958] Ready (ping: 11ms).
Connected to Blynk Server
[20344] Time sync: OK

The problem you are probably running into is that the AT firmware and how you may be wiring things up is tried and true on an ESP-01… but I have yet to find a single working instance of it being done with a NodeMCU.

So, basically you may not be wiring it correctly, using wrong power, the Blynk shield library may not be communication to it correctly… too many unknown variables.


#35

Hmmm… this is wrong…

You should be going from UNO pin 2 to ESP TX and UNO pin 3 to ESP RX

Also, you CANNOT power the NodeMCU from the Arduino, or visa versa… they both need their own 5v USB power… but yes, still shared GND, although that might already be covered if they are using the same power bank or PC USB ports.


#36

Oops !! I will change the Tx and Rx pins.
Power is provided from a solid lab bench power supply. So no issues with power. And i have ground in common between them.


#37

Why do you think it would be any different to an ESP-01?


#38

That might be the key to whole issue there??? They need to communicate like mouth to ear… not mouth to mouth… that is a whole different form of communication :kiss: :stuck_out_tongue_winking_eye:


#39

Only because I haven’t found a web link saying different… lots of people asking how, and being told pretty much the same thing as here… Why?? :smiley:


#40

Can you please share the working code bit (example sketch) ? So that i can put that on my uno.