BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino UNO W5100 shield can not be connecting to local server!


#1

Hi friends. today I bought W5100 arduino ethernet shield but it cannot be connecting to the local server.
the serial monitor like this:

[0] Getting IP...
[5524] IP:10.5.51.4
[5524] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.4 on Arduino Uno

[5638] Connecting to blynk-cloud.com:80
[6169] Invalid auth token
[10868] Connecting to blynk-cloud.com:80

the sketch I using:

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial


#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "f5b6ec2ba1aa4e189e3f034a3fdae070";
char server[] = "10.5.50.18";

#define W5100_CS  10
#define SDCARD_CS 4

void setup()
{
  // Debug console
  Serial.begin(9600);

  pinMode(SDCARD_CS, OUTPUT);
  digitalWrite(SDCARD_CS, HIGH); // Deselect the SD card

  Blynk.begin(auth);
  // You can also specify server:
  Blynk.begin(auth, server, 8080);
}

void loop()
{
  Blynk.run();
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!
}

thanks


#2

@ErfanDL: Just delete the

Blynk.begin(auth); 

in void setup() and only use

Blynk.begin(auth, server, 8080); 

This will connect to your local server 10.5.50.18


#3

Like buying a Horse and buggy… and wondering why you are getting passed on the freeway :stuck_out_tongue_winking_eye:

@IBK caught it before I could type :smiley:


#4

thanks a lot. the problem is solved. ( I did not see the Blynk.begin(auth); ) :rofl:


#5

:joy::joy::joy: