BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino Uno USB serial, blynk script service is unable to connect

android

#1

My project consisted of a LDR and a PIR sensor module interfaced to an Arduino Uno which i was controlling via my phone. It was working fine but isn’t anymore. Everytime I try to run the blynk-ser.sh file
this message is displayed.

2018/12/01 22:26:52 socat[31483] N opening connection to AF=2 188.166.206.43:8441
2018/12/01 22:26:52 socat[31483] E connect(6, AF=2 188.166.206.43:8441, 16): Connection refused
2018/12/01 22:26:52 socat[31483] N exit(1)
Reconnecting in 3s...

I have no idea why this is happening
Does anyone have a solution?
If so, please help.


#2

Something else using same COM/Serial port is the most common reason for the blynk-ser method to fail.


#3

Thanks but doesn’t seem to be the case here


#4

Well, that is ALL that thing does, convert serial to TCP/IP, so there is probably something blocking it… port conflict, incorrect BAUD, AV/firewall, bad connection, bad cable, even bad timing (I have issues auto running mine at boot while my UPS is auto scanning for its own port to use)…


#5

May be. Tried a lot of things, nothing seems to work


#6

Took a bit to catch this… I reformatted your post for clarity…

Why using the wrong port? 8441 has been changed…


#7

Thanks.
But now I am getting “socket closed by peer” instead of connection refused.


#8

Are you trying to connect to a Local Server IP or Blynk cloud… if the latter just try the usual blynk-cloud.com


#9

I did. It is back to connection refused.


#10

Can you show new terminal printout… and perhaps even the script setup.


#11


#12


#13

You are still using the wrong ports in your blynk-ser.sh script :stuck_out_tongue:


#14

my bad.
Thanks a lot. :grinning:


#15

So… works? Solved?


#16

Yes