Arduino nano, EtherCard.h and blynk

Did someone use arduino nano 328 with ENC28J60
(with EtherCard.h) ?

im trying to do simple ethernet blynk relay on it.

Pleace some one help me with sketch or link to ness. libraries)))) Im failed to find it
What library should i use to run blynk on nano with that module?

Hello. Did you look into ?

Yep! It the first that i download - but Arduino IDE gives me alot of mistakes… Wait a bit ill wrote whem here))) Thaks for fast answer

should i get ethernet library from there?
ВНИМАНИЕ: Категория ‘’ в библиотеке UIPEthernet не является действительной. Установка на ‘Uncategorized’

Just warning)))


I think it is fine. @vshymanskyy should know better.

Can you help me a little more please… I never used any arduino with arduino IDE.(only esps before)
so I
chmoded to 777 my /dev/ttyUSB0 with nano connected
and check sketch on errors
after i press “write sketch button” and my nano flashes with tx and rx
but there were no "."s written below in log.
Is it normal? did i flash my nano after tx and rx stops blink?
where were no mistakes in log below

One more question
Blynk.begin(auth, IPAddress(XXX,XXX,XXX,XXX), 8888); - what does 8888 mean?
Ohh suppose its a custom port number)))

Hop arduino
hop hop arduino
Hop arduino meaaaaaa…

@zara I’m guessing you are using some unix derivative from the chmod, which OS precisely?

Paste the precise sketch you are using and ensure it is formatted by pressing the </> once you have highlighted the code.

i have found all my mistakes and problem are solved now)))
Thank you for your reply
Just IDE did not write a lot of “.” and “% of complete” than it fashes nano)))

1 Like

try to use this newest one:
there is more universal and have not warning on compile.

my basic setup for ENC28J60 with Arduino Pro Mini is:
UIPEthernet.h (
Arduino IDE 1.0.6

I tried several releases of IDE but only 1.0.6 works perfectly without doubt of compiling with this setup.
The problem is the less program memory. When you use these libraries and Blynk stuffs (run Blynk and SimpleTimer), you have only a few bytes for your own code. (e.g. 27338 byte used of 30720 byte maximum) It is enough in most of cases (relay control, temp measure, etc.) but in case of combine different tasks you can run out of free memory easily.


Please read the docs about how to free a few KB

@vshymanskyy, you mean ‘Minimizing footprint’ section of Blynk docs?
I tried add these lines to my sample code (my sample code contains only neccessary libraries and Blynk codes without any further user program lines):

#define BLYNK_NO_BUILTIN   // Disable built-in analog & digital pin operations
#define BLYNK_NO_FLOAT     // Disable float operations

and total bytes decreased to 26090 bytes from 27338 bytes.

May can it shrink more?

additionally, you may want to remove BLYNK_PRINT and corresponding Serial.begin

BTW, Blynk is even smaller than MQTT (and uses far less bandwidth).
So, unfortunately I don’t think you have the right hardware for your project… if you run out of flash - just pick a bigger controller or change the hardware completely.

Thanks, but it is not a huge problem for me because I had an old ENC28J60 and I would utilize it. Now it works with 6 relays for switch LED lamps outside my house. I use ESP8266 standalone for all my other projects.

…and some Blynk features (e.g. setProperty) are not compatible with libraries for ENC28J60, so possibilities are less to use for this hardware instead of others…