BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Arduino mega usb connect

Hello guys.
Im working on an aquaponic system, wich i want to control and monitor.
The arduino mega is connected with the pc with usb.
First i made a local server, to have more energy in Blynk app. Its works i tried.
I had the ip adress like (xxx.xxx.xx.xx), ad a port (xxxx).
In blynk-ser.bat i make the following changes:
set COMM_PORT=COM3 - in this port connected the Mega
set COMM_BAUD=9600
set SERV_ADDR=xxx.xxx.xx.xx - my local server ip adress
set SERV_PORT=xxxx - and the port 9443
I run the .bat in cmd
Connect(“xxx.xxx.xx.xx”, “9443”) - OK
InOut() START
DSR is OFF
Received EOF
EVENT_CLOSE
InOut() - STOP
Disconnect() - OK
Its keep write the following over and over. But in Blynk app the Mega is not online.
Its funny, when i useing another account and the default blynk-cloud.com and 8080 port its works fine, but there is just 2000energy, not enough.
I always watching the tokens to be right.
Any idea?

I think you’ll find that the message told you that the admin page was at xxx.xxx.xxx.xxx and port 9443 along with the default username and password.

Unless you’ve changed the server.properties, regular connections will be on port 8080 or 80.
If you’ve installed SSL certificates then you may be able to connect on port 9443, but that shouldn’t be your first choice.

Long term, you need a proper IoT connection method, which will probably be a NodeMCU or ESP32.

Have you set-up a DDNS service and update client, and done the necessary port forwarding on your router to enable you to access the local server on your phone when you are away from home?

In my opinion, setting-up and maintaining your own local server and managing the DDNS process is more expensive than buying energy for your project.

Pete.

I’m just what to work on localhost. I do the following steps
1.
Blynk Server 0.41.13 successfully started.
All server output is stored in folder ‘C:\Users\CsoKKer\Documents.\logs’ file.
Your Admin url is https://192.168.0.14:9443/admin
Your Admin login email is admin@blynk.cc
Your Admin password is admin

2. in blynk-sr.bat
set COMM_PORT=COM3
set COMM_BAUD=9600
set SERV_ADDR=192.168.0.14
set SERV_PORT=9443

3. in blynk app
i add the 192.168.0.14 ip an the 9443 port.
look for the token, and write into the arduino code, usb exaple
upload the code to the Mega
close the arduino.ide, and start the blynk-server.bat

And nothing hapens whit the Mega when i try to light a led on, in Blynk,
Blynk says that the board not connected.
Mega is connected via usb with my pc.

So what happens when you put port 8080 in your bat h file?

Pete.

You where right, now it’s works.
It’s solved the problem, now i have energy and connected via usb, not the best way, but i must work whit what i have.
Thank you Pete.

Cheesecake.