BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"App can't initialize a connection to server " problem with local server

Hello ,
I really need an urgent help , I am currently working in a graduation project with raspberry pi 4
I already installed Blynk app in my phone and create my first project , but because the blynk server give limited energy , I decided to create me local server on raspberry pi .
I tried several times to connect to my local server using raspberry ip address (the ip taken from home network through ethernet cable )
but the message "App can’t initialize a connection to server "
How can i solve this problem ??
I’ve already see all the related solutions to this topic in the community but nothing work .التقاط

Some information about exactly what settings you’ve entered into the custom server section of the app, and whether your mobile device is connected via WiFi or cellular data would be useful.

Pete.

My mobile is connected to WiFi ,
I just create a local server follows the instruction here “https://github.com/blynkkk/blynk-server#blynk-server
and the server started correctly in my pi , when I try to log from the app I didn’t see any related info in the log file

So in the app, what custom server settings did you enter?

Pete.

in the app it is just asked for the IP address and port
I entered pi IP address and 9443

Any help !

And did you choose the 'Create new account" option in the app, or the “Login” option?

Have you double-checked that the IP address and port you entered are correct?

Is your local server actually running (can you still log-in to the admin console)?

Pete.

I used create new account ,
yes i checked it through ifconfig in my pi
yes my admin console work correctly .

So, at what point in the ‘Create new account’ process does the message occur?

Pete.

I put my gmail email and a password , i click sign up and then it take a long time then replied by the " Sorry,…" message . sometimes it is saying “retrying to connect to server”

Can you double-check the IP address and port info that you typed into the custom server screen of the app to ensure that you haven’t accidentally mis-typed them?

Pete.

I checked it again and again ,no changes :frowning: :frowning:

Can you ping your local server IP from the device running the app?

Pete.

it said" trying to connect to server " then “Sorry…”

i ping my ip from laptop , and it is ook

That’s not the same.
Can you successfully ping the server from the device running the app?

Pete.

I run the app on my phone, did you mean ping from phone , how can i do that?

Yes.

You’d normally use an app that allows you to initiate a ping

Pete.

it gives me “request timed out”