BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Android app is not working properly

Hello everyone!

Few days ago I just installed the app after a really long break.

I am using a local server installed on a raspberry pi b. The raspberry pi is os is not using the desktop interface. Blynk is the only thing running in the background.

Right now, I am using a single device, but I have been running the same configuration before with even more widgets and more devices with no problems long time ago.

The apps is barely responsive and the behavior is was not always like this. It had few moments when it worked fine. I deleted the cache and the data, even reinstalled it twice. It helps for a short time. The plus/minus buttons are barely responsive, but after multiple tape some of them are registered.The smartphone warms up after a while after I keep trying to use the app.

I updated the app last night I think, but the same issues happened on the previous version too.

My smartphone is the s8+ with android 9.0, not a custom ROM, but a Samsung ROM

Don’t have access to YouTube but maybe posting your code would be the first step.

What version of the app are you running?
What version of Blynk server are you running?
What model of Pi is this running on, what version of the Pi OS and Java are you running, and are you using an Ethernet or WiFi connection?

Are your App custom server settings pointing directly at the IP address of the Blynk server, or to a DDNS URL?

Have you tried restarting your phone, Router and Blynk server, along with any wireless access points, Ethernet switches etc on your network?

Pete.

Thank you, PeteKnight.

  • The Blynk android app I am using is: 2.27.20.
  • blynk server: 0.41.14-java 8
  • raspberry pi 2 b with os buster connected by ethernet with fixed ip - lan only for now - i am using it’s lan ip
    Java 8
    openjdk 1.8.0_212
    Runtime environment build 1.8.0_212-8u212-b01-1+rpi1-b01
    Openjdk client vm build 25.212-b01, mixed mode
    I just ran again: sudo apt update,full upgrade, dist-upgrade and rebooted it

All the networking equipment is restarted just in case too. I do everything by ssh to the rpi server.

As I said before, android app restarted, reinstalled, cleared cache and data reinstalled again

I updated the last changes I made on GitHub, but that’s irelevant, as exactly the same code worked perfectly fine before for months.

Just a clarification, the connection to the server works both ways, any change I manage to do through the android app, gets reflected to the hardware.

So, months ago, when I used it last time and everything used to work fine.

I found the trigger: It’s the GPS trigger widget. The app becomes unresponsive as soon as I set a VPIN, it does not even have to be one that that is used by the hardware.Any VPIN I set to the GPS trigger causes the issue.

@BlynkAndroidDev, think you can have a look, please?

1 Like

I’m investigating this issue, i hope to release a fix soon

1 Like

much appreciated!

I just tested the same project on the s9 with android 10 and the issue is not present there, it appears to be working fine on android 10.

1 Like

Yes, it reproduces on older Android versions, I’m not sure about all supported by, but definitely, it may reproduce on Android 6-9.

1 Like

It appears to work fine now. Thank you!

1 Like