Always disconnected

Hello,
I need help because I have the messages :
Connecting to Livebox-3262
[4209] Connected to WiFi
[4209] My IP: 192.168.1.15
[4209] Blynk v0.3.1
[5001] Connecting to cloud.blynk.cc:8442
[7217] Login timeout
[10217] Connecting to cloud.blynk.cc:8442
[10429] Ready (ping: 2ms).
[15430] Connecting to cloud.blynk.cc:8442
[15634] Ready (ping: 1ms).
[30635] Connecting to cloud.blynk.cc:8442
and so one…
my sketch (simple):

```#include <ESP8266WiFi.h>
```#include <BlynkSimpleEsp8266.h>
// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "2bb9fd7f113................";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, "Livebox-3262", "here my pass");
  while (Blynk.connect() == false) {
    // Wait until connected
  }
}

void loop()
{
  Blynk.run();
}

I use an ESP01 and also tried 2 ESP12E with same results.
Where is my pb please?
Thanks

Hello, please try latest Blynk library from trunk.

Please edit your first post. Code should be formatted.
Wrap the code by pressing this magic button (Backtick`) 3 times (before the code and after it):**

Example:

 ``` <--- insert this 
 Paste your code here
 ``` <--- insert this 

This makes your code beautiful with highlighted syntax, like this:

//comment goes here 
void helloWorld() { 
   String message =  "hello" + "world"; 
}

You can also select the code and press </> button in the top menu:

Hello,
(Excuse me for the bad characters)
I have the Blynk_v0.3.1 libraries (from https://github.com/blynkkk/blynk-library/releases/tag/v0.3.1) is it ok?
Thanks.

No. you need latest one from trunk to be sure problem not in library.

I am newbie, can you give me a link to that latest libraries, please.
Thanks.

https://github.com/blynkkk/blynk-library press on button “download zip”

Thank you very much,
All the files in \Arduino\libraries\Blynk were successfully updated.
But the result was : it worked one time only.
After many attempts… I am very upset because I found that :
It doesn’t work when I restart with pushbutton on rst (rest).
And it works when I restart plugin off / on the power supply???
(Does any one have an explanation or I am in the moon?)
Now I am using a SHT21 sensor with temperature and humidity and everything is working perfectly.
Thanks a lot.

Read your message twice but didn’t get it. Did you resolve issue? What was the problem?

The pb is solved strangely.
It doesn’t work when I reset the ESP8266-12E (pin 1 to gnd).
I must unplug then replug the power supply of the ESP to make it work without disconnections. that’s what I don’t understand.
Have you ever seen that?
Thank you.

Looks like power issue…