Add new device to blynk IoT

Hi All

I stated Blynk iOT today

I am suffering connect device to the App
My NodeMCU already connected to the phone but it does not show in the add new device menu Even I pressed Ready several time
I already created a project on dashboard
Please advice
This is the code that I upload to the device

// Fill-in information from your Blynk Template here
#define BLYNK_TEMPLATE_ID "TMPLqtXAz1gM"
#define BLYNK_DEVICE_NAME "MyRoom"
#define BLYNK_AUTH_TOKEN            "UgJW9zKCla"
#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG
#define switch1    16
#define switch2    5
#define switch3    4
#define switch4    3

#define APP_DEBUG
char ssid[] = "";
char pass[] = "";
// Uncomment your board, or configure a custom board in Settings.h
//#define USE_SPARKFUN_BLYNK_BOARD
//#define USE_NODE_MCU_BOARD
//#define USE_WITTY_CLOUD_BOARD
//#define USE_WEMOS_D1_MINI
char auth[] = BLYNK_AUTH_TOKEN;
#include "BlynkEdgent.h"

void setup()
{
  Serial.begin(115200);
  delay(100);
  pinMode(switch1 , OUTPUT);
  pinMode(switch2 , OUTPUT);
  pinMode(switch3 , OUTPUT);
  pinMode(switch4 , OUTPUT);
 // BlynkEdgent.begin();
   Blynk.begin(auth, ssid, pass);
}

void loop() {
  //BlynkEdgent.run();
}
BLYNK_WRITE(V0)
{
  
  if(param.asInt()){
  digitalWrite(switch1, LOW);
    digitalWrite(switch2, LOW);
    digitalWrite(switch3, LOW);
    digitalWrite(switch4, LOW);
  }
  else {
    digitalWrite(switch1, HIGH);
    digitalWrite(switch2, HIGH);
    digitalWrite(switch3, HIGH);
    digitalWrite(switch4, HIGH);
  }
}

@dayan please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:
```

Pete.

1 Like

Thanks for the advice
No device LED is not blinking at all

The above code is uploaded successfully
Please advice

You haven’t un-commented the correct line of code for your board.

What exactly does this mean?

Pete.

What exactly does this mean?

This mean NodeMcu already connected to the phone wifi

So are you saying that you’re using your phone as a hotspot?

Pete.

No my phone is connected to my Router and also NodeMcu connected to the router using same credentials, What I tried to say that device is working and connecting to phone but not connecting to the app

//#define USE_NODE_MCU_BOARD

This is corrected now but problem is existing

When I Pressed reset button on the Nodemcu then Serial monitor saya
“[188294] Invalid auth token”
[311627] Current time: Wed Dec 8 14:09:35 2021
[311627] Connecting to blynk.cloud:443
[313693] Invalid auth token

Please advice

Dear Mr Pete now it is working
Thanks for the help