Active relay causes Blynk to disconnect / EMF?

Hello there

I’m currently working (again) on a project with the Blynk application.

I use an Arduino UNO in combination with a W5100 Ethernet Shield. With the help of this hardware, i want to control a pump, light, … of a swimming pool via a Blynk GUI (Blynk Server). The switching is done by a common 8 channel relay board, which is galvanically isolated by the help of the built-on optocouplers. It’s also powered by a separate 5VDC power supply.

Now I’ve realized, that when switching big loads (e.g. the pump motor) on/off blynk seems to disconnect from the server. If I disconnect the load from the relay this doesn’t happen anymore. I found the same problem on the following link:

(Unfortunately) this user had a bug in his code. In my application, I currently don’t even use a custom code. I just use the GUI to control the digital Outputs.

I think it has to be the EMF that makes the Arduino disconnect. Has anybody ever experienced anything similar? Any suggestions are desired :slight_smile:

Thank you so much!

If the relay board has a JD-VCC jumper in place then you are almost certainly bypassing the optoisolators on your relay board.
Even so, you may need to add a suitably capacitor across your relay terminals.

A bit more reading for you…


Hey Pete

Thank you so much for your fast response!

The JD-VVC jumper is not installed and supplied from a separate power supply.

I just read the posts you sent me. I think maybe the capacitors could help me. Unfortunately I’m not quite sure about the sizing of those… Is there any rule of thumb that could help me with this?

The only time I’ve ever needed to add a capacitor across a relay contacts was with a 12v AC door release mechanism (the type used on door entry systems, where the door lock makes a buzzing noise when the lock has been released).
I experimented a little and eventually settled on a 220uf non-polarised capacitor.
In your case the capacitor will need to be rated at your mains voltage or higher. Be careful when doing this, as capacitors can store a large amount of power and give you a nasty shock unless you discharge them.


Hey Pete

Thanks for your response. Today I’ve tried your capacitor advice. Unfortunately without success. Do you have any other suggestions or thoughts?

Experiment with different capacitor sizes.
Try an X-rated capacitor across Line and Neutral
Experiment with positioning the capacitors. As a general rule they should be as close to the source of the interference as possible. If it’s the relay contacts that are the issue then close to the relay. If it’s the device being switched then as close to the motor etc that is having its power switched.


I have had the same issue when activating the relay with ESP32 board, sometimes the ESP reboots sometimes the relay output voltage 12 VDC falls down until 8 V.

I fixed it by removing the jumper and appling an external 5V to the Relay 5V Pin and also the external ground to the relay GND Pin… very important is that the 12 VDC GND (Load supply) and the External 5V ground are completely seperated and isolated… I hope this will help…


Hey there

The mentioned jumper wasn’t installed.
Nevertheless, I’ve found another solution. All of the components were installed in a control cabinet. Many of the 5V lines were next to the mains voltage. By mounting the Arduino in a separate box outside this cabinet I was able to solve this problem.

Thank you guys :slight_smile: