Accessing csv data from Pi Zero W Blynk server

@Dmitriy my Pi Zero W Blynk server, hereafter just called W, runs on 2 subnets and 2 IP’s.

When accessed via wireless the IP is and when accessed via the LAN it is
The wireless is for out in the field as it’s own Access Point and the LAN is obviously for internal use.

Yesterday I had the wrong LAN gateway server set for the W and it came up with the normal inaccessible IP of 169.254.x.x for the W. I quickly changed it to the correct gateway but I have an issue obtaining the csv data from the app.

If I use the API then and both provide the correct csv file.

However if I make the request from the app it offers me the csv download from

I’m guessing this is somehow related to me setting the wrong LAN gateway for the W. I have tried clearing the data from the app and this appears fine but when I again try to request the csv it insists on a download link of 169.254.x.x.

Do I need to physically remove some files from the server before it will start to give the correct download IP and if so which files are they, thanks?

Edit: I tried renaming the Historyxxxx .bin files in /data/user and rebooting the W. The server created new files but sent from the app they are still for the incorrect 169.254.x.x.

You need to set property for Otherwise server will try to detect host by itself.

That’s fixed it, thanks @Dmitriy

1 Like