AC Dimmer control using google assistance and alexa to with the help of IFTTT

I want to control my dimmer with both , Google assistant or alexa too,

When I say to google/alexa, set dimmer at 25% it goes dim with 25%

When I tell him that my dimmer/ bulb dim at 50%, then let it happens

What have you done/tried so far, and what issues have you encountered?

Are you wanting to use just 0%, 25%, 50%, 75% and 100%, or are you wanting any random value between 0 and 100?

Do you have an IFTTT paid account?


No sir I have only 3 free applet yes, you are right , just 25/50/100%

I am getting problem to create webhook request, I don’t know how to fill it for

Same like this article

What problem, be specific!

I’d suggest that instead of giving one-line vague answers, you take more time to explain in detail.

Three free applets won’t be sufficient for Alexa and Google Home, unless you manage to capture the percentage as a parameter and pass it to the Blynk API call. I’m not sure if that’s possible, but that’s an IFTTT question rather than a Blynk one.


Sorry for my sili mistake , I just wanted to control dimmer with alexa, and I don’t know how to make webhook request or pass it to the blynk API,

So please could you help me,

How to make webhook request,

There are lots of examples on the forum.
I realise that you’ve commented on one of those, about your inability to insert a percentage symbol into the “What do you want to say” field in IFTTT, but there are some good tutorials and discussions if you do some searching and reading.


I don’t find my answers, yes you right sir I did comments but I didn’t get any answers of my question if you can please help me how to fill webhook and how to put % symbols in ifttt field. Or any other option instead.

Try leaving-out the percentage symbol for now, simply go for “set dimmer to 75”.


what about URL field, and after value i am unable to

Hello Everyone can somebody help me to create the URL OF blynk api for IFTTT Google assistance applet.

#include <ESP8266WiFi.h>           // Header file for Wifi Module 
#include <BlynkSimpleEsp8266.h>  // header file for blynk 
#include <RBDdimmer.h>           // header file for robodyn dimmer

char auth[] = "";  // blynk auth key 

char ssid[] = "Yogendra";   // Wifi Name
char pass[] = "Jamsariya";  // Wifi Password

#define outputPin  D2  // PWM pin for dimmer
#define zerocross  D5 // for boards with CHANGEBLE input pins

dimmerLamp dimmer(outputPin, zerocross); //initialase port for dimmer for ESP8266, ESP32, Arduino due boards

int outVal = 0; // Intialisation value for dimmer
int dim_val; // dimmer value to dim the appliance

void setup()
  Serial.begin(9600); // begin serial communication
  dimmer.begin(NORMAL_MODE, ON); //dimmer initialisation: name.begin(MODE, STATE)
  Blynk.begin(auth, ssid, pass); // begin blynk server

void loop()
{; // Run blynk server

BLYNK_WRITE(V0)  {  // Set to your virtual pin  
  outVal = param.asInt(); // Get State of Virtual Button
  dim_val = map(outVal, 0, 1023, 0, 100); // mapped the value for dimmer
  dimmer.setPower(dim_val);               // Set dimmer power
  Blynk.virtualWrite(V1, dim_val); //sending to Blynk

I’ve merged your two topics together as they are about the same subject.
Please don’t keep creating new topics in this way.


Your BLYNK_WRITE(V0) callback is expecting to see values in the 0-1023 range.

75% of 1023 is 767, so your API call would end in value=767


still not working when i say 100% its goes off and when i say 50% or any % not responding

sorry for my mistake here is my webhook details

So, despite what you said earlier, you aren’t wanting to create applets for a small number of fixed brightness values…

instead, you’re wanting to capture the spoken percentage and pass it as a parameter to the API call?


Dear, Sir that time I didn’t know how to put symbols and % sing in what’ do you want say blocks , but for now I know how to put symbols in blocks

If We use defferent value we need more applet but according to this process we can mange all in one in one applet

So my hearty request to you sir,

Could you help me to complete this way,

As I said earlier…

Either way, your Blynk code is expecting values between 0 and 1023, so unless you say “1023 percent” then you either have to change the data in IFTTT before it’s sent, or adjust your Blynk code and remove the re-mapping of the incoming values.


1 Like